Logo hatimi.net

Programmation web

Systèmes d'exploitation

Connexion...

 


 

Les structures conditionnelles

    

Les structures conditionnelles permettent d'exécuter une instruction si une condition est vraie.
Il existe deux manière pour écrire une instruction conditionnelle :

  • Forme Si-FinSi
  • Forme Si-SiNon-FinSi

1. Forme Si-FinSi

Syntaxe :

Si   condition   Alors  
      Action
FinSi

Lorsque l’évolution de la condition produit la valeur  vrai : l'action  est exécutée.
L'action peut être soit :

  • Une instruction.
  • Un ensemble d’instructions.


Exemple :
Algorithme maximum
       Variables
        A, B : réels
DEBUT
         Ecrire (" Donner la première valeur :")
         Lire (A)
         Ecrire (" Donner la deuxième valeur :")
         Lire (B)
         Si A > B    Alors
              Ecrire (" Le maximum est :",A)
         FinSi
         Si B > A    Alors
              Ecrire (" Le maximum est :",B)
         FinSi
         Si A==B    Alors
              Ecrire (" Les deux valeurs sont égales")
         FinSi
FIN


2. Forme Si-SiNon-FinSi

Syntaxe :

Si   condition   Alors  
       Action1
Sinon
       Action2
FinSi
Lorsque l’évolution de la condition produit la valeur :

  • Vrai : l'action 1 est exécutée.
  • Faux : l'action 2 est exécutée

 Action 1, comme l’action 2, peut être soit :

  • Une instruction.
  • Un ensemble d’instructions.


Exemple :
Ecrire l’algorithme permettant d’afficher la valeur absolue de la différence entre deux nombres saisis au clavier.
Solution :
Nous déclarons trois variables de type réel .Les deux  premiers A et B reçoivent les valeurs des nombres traités, le troisième C reçoit la différence.
Pour que la différence soit toujours positive il faut calculer A-B si A > B, et B-A si A < B .Nous avons donc une structure alternative.

Algorithme val_absolue
       Variables
A, B, C : réels
DEBUT
     //saisie des nombre A et B
     Ecrire (" entrer deux nombre ")
     Lire (A, B)
     //calcul de différence
     Si A > B    Alors
          C ← A - B
     Sinon  
          C ← B – A
     FinSi
     //Affichage du résultat
     Ecrire (" la valeur absolue de la différence est ", C)
FIN

Dernière mise à jour le 25 décembre 2015 à 00h25m04s

Partager
submit to reddit Delicious Delicious
Share on MyspaceMyspace FriendFeed

0  Commentaires




Ajouter un commentaire :

Nom               :
Commentaire :